
dSTORM/GSDIM Data Analysis Session (EMBL Super-resolution course, July 20-25, 2015) 

 

Software: rapidSTORM 3.2, Lama, Fiji 

 

1) Primary analysis with rapidSTORM: single-molecule localization software 

 Analyzing a tif-stack: getting to know rapidSTORM 

 Input parameters 

 Image display settings 

 Drift correction 

 Reloading localization tables 

 Grouping of single-molecule fluorescence signal 

 

2) Secondary analysis with Fiji 

 General image display settings 

 Intensity profiles 

 Particle analysis 

 

3) Secondary analysis with Lama 

 Computing images with Lama 

 Localization precision 

 Morphological cluster analysis 

 Cluster analysis using Ripley’s functions  



dSTORM/GSDIM: practical course on data analysis 
Mike Heilemann and Franziska Fricke  

Johann Wolfgang Goethe-University, Frankfurt a.M. 

Software: Lama, rapidSTORM 3.2, Fiji 

Check on computer: Lama, rapidSTORM 3.2, Fiji, pdf reader (e.g. Adobe Acrobat) and Excel (or similar) 

Samples: Start with a good sample of microtubules or vimentin for getting to know the software. For 
cluster analysis, receptors, Env or clathrin are suitable candidates. 

General: For every section, make slides from your images, plots or results to obtain a .ppt presentation 
that may serve as a protocol for later use. The slides will also help you for your final data presentation. 

0) Open GSD files 

 Start Fiji (version “June 2014” or later) 
 File → Import → Bio-Formats 
 Open .lif-files (Leica image format) 
 Select data series (“blinking”) 
 Save as .tif-stack 
 

1) Primary analysis with rapidSTORM 

Start with single-color single-molecule movie of microtubules 

1.1 Analyze .tif-stack: getting to know rapidSTORM 
 Drag & drop .tif-file 
 Set output filename 
 Set pixel size (for us: 160 nm, here: 100nm) 
 Set FWHM (≈ λ/2) (for us: 400 nm, here: to be determined) 
 Set Intensity threshold: start with 1000 
 Select Lama output format: Localization file → enable “Output only Malk fields (x,y,z,t,I)” (for 

2D data: localization list will contain (x,y,t,I) as columns) 
 Press “Run” (bottom of window); when calculation finished, press “save current image” 
 Look at output image and adjust histogram normalization (range: 0 – 1) 
 Open localization file (*.txt) to identify fluorophore positions x/y (unit = nm), intensity I, frame 

number t, absolute number of localizations etc. 
 NB: output file names should be renamed every time (rapidSTORM overwrites files) 

1.2 Adjust input parameters 
 Determine your PSF FWHM: Add output module “Estimate PSF form” (number of spots used 

in estimation = 10); write down your results 
 look at output image and adjust histogram normalization and intensity cutoff (range: 0 – 1) 



 Remove “Estimate PSF form”: Select “Remove output” 
 Use different intensity thresholds: e.g. 300 (very low), 5000 (very high) → check your resulƟng 

image and localization table; save one of the images for your results 
Rejects fluorophores with Gaussian intensity below threshold; plot absolute number of 
localizations vs. intensity threshold 

1.3 Adjust image display settings 
 Set “Minimum localization strength” to 1000, 10000 → can reduce background 

Rejects localizations with a Gaussian intensity below threshold 
 Adjust output image pixel size: set “Resolution in X/Y direction” to 50 nm, 5 nm; save both 

images for your results 
Compare images with different pixel size. 

1.4 Qualitatively correct for linear drift 
 For a simple, visual drift analysis: set “color palette for display” to “vary hue with coordinate 

value”/”frame number”; set range of frames in displayed image, e.g. 0-10000 
 Linear drift correction: a drift in x-direction of 50 pm/frame can be corrected for by entering 

x/y/z values of -50/0/0 

1.5 Reload localization file with rapidSTORM 
 Select „Job“ → „Replay“ → „Minimal“ 
 Load input file by clicking “Select”, choose “*.txt” localization file to load 
 Change output filename 
 Add output modules: e.g. “Image display” and “Localization file” 
 Useful for stitching two or more tif-stacks together: (i) analyze multiple tif-stacks with 

rapidSTORM and generate localization files; (ii) select number of input channels according to 
the number of localization files → set ”Join inputs” to “In Ɵme” 

1.6 Grouping of single-molecule fluorescence signal  
 Load a single-molecule .tif stack of a sample stained for TNFR1 
 Expression filter → Add output module “Track emissions”, select “Track emissions”, set the 

following values: 
o Distance threshold: e.g. 2 (in units of localization precision ∆x) 
o Allowed blinking interval: e.g. 0 (number of camera frames) 
o Diffusion constant and mobility constant: set both to 0 (fixed sample) 
o Add output module: Localization file 

 Go back to „Expression filter“, set „Number of Expressions” to 2 
 Set “Value to assign to” to sigmaposx and sigmaposy 
 Set “Expression to assign from” to 10 nm for both 

Open the localization file and discuss the results.  



2) Secondary analysis with Fiji 

2.1 General image display settings 
 Load microtubules image into Fiji (pixel size 10 nm) 
 Image → Type → 8 bit 
 Image → Adjust: Brightness/Contrast, Threshold 
 Image → LUTs 
 Process → Filters → Gaussian Blur, set sigma to 1 pixel (= 10 nm) 
 Analyze → Set Scale (convert pixel to μm); Analyze → Tools → Scale Bar (insert scale bar) 

Save image for your results. 

2.2 Intensity Profiles 
 Load microtubules image into Fiji (pixel size 10 nm) 
 Draw a straight line (line tool) perpendicular to a single tubulin filament 
 Adjust line width (unit = pixel) 
 Analyze → Plot Profile (Ctrl-K); 

Determine radial profile of microtubules and estimate FWHM. Do you see two peaks? Save profile for your 
results. 

2.3 Particle Analysis 
 Load a super-resolution image of TNFR1 (pixel size 10 nm) 
 Set image type 8 bit 
 Set analysis parameters: Analyze → Set Measurements, select “Area”, “Integrated Density” 
 Select ROI (approx. 10 μm x 10 μm); Measure ROI size: Analyze → Measure 
 Set threshold: Image → Adjust → Threshold, select appropriate value (e.g. 30 - 255) 
 Analyze particles: Analyze → Analyze ParƟcles 

o set “Size” to 16-Infinity (in pixel units) 
o show: masks 
o select “Display results” 

 Particle statistics: Results → Summarize; Results → Distribution (e.g. Parameter: Area, specify 
bin: 10, range: 10-100) 

Determine particle density and mean particle size/radius (e.g. 5000 nm2 → radius ≈ 40 nm); Plot 
distributions of cluster area and intensity; save for your results 
 

  



3) Secondary analysis with Lama 

The cluster analysis is ideally performed with image data of TNFR1, Env or clathrin. Lama reads 
rapidSTORM localization files saved as (x,y,z,t,I)-field (“Malk”-field).  

3.1 Compute One Color Image: Calculates image and localization table based on your ROI 
 Start with TNFR1 .txt 
 Select “Main” tab: 

o “Input” tab: Load .txt localization file in “Malk”-format (x,y,z,t,I) with “Browse”; Select 
“single localization file” 

o “ROI” tab: Define ROI by setting min and max values (e.g. x [µm] = 0-40, y [µm] = 0-40,  
t [frames] = 0-11000, Int [A.D.] = 0-1000000, CBC = -1 - 1) 

o “Setup” tab: “Conversion Factor” converts camera counts in photons (this depends on 
camera settings; for us: 4); “Sigma from Gaussian Fit”: enter sigma value used for 
rapidSTORM (sigma = FWHM/2.35; e.g. sigma = 149 nm for FWHM = 350 nm for 
λ = 700 nm), important for localization precision; “Integration Time per Frame”: enter 
camera acquisition time (for us: 0.03 s) 

 Select “Visualize” tab, “Image” tab 
o set “Desired Pixel Size” = 10 
o enable “Choose Maximum Manually” = 255  (1 localization = 1 greyscale up to 255) 
o select “Compute Intensity based Image” 

 Press “Compute” (protocol (cmd) window shows when calculation is finished: “…job done…”) 
 Output folder “*_statMIA” contains three output files: localization file of ROI (locs_roi.txt), 

super-resolution image of ROI (roi_int.png), settings file (offset.txt) 
Open “roi_int.png” in Fiji, adjust brightness and determine the intensity (localization counts) in a single 
cluster; keep this image for your results 
Optional: in “Visualize” tab, “Image” tab: enable “Enable Convolution” = 10 (image is Gaussian blurred); 
this generates new output image “roi_iwm.png”; open with Fiji 

3.2 Compute Localization Precision 
  for large files, define appropriate ROI (e.g. 5 μm x 5 μm) and a series of frames in the middle 

of the movie e.g. t [frames] = 5000-6000 in “Main” tab, “ROI” tab 
 Select “Accuracy” tab, “Theoretical” tab 

o set “Setup Pixel Size” = 160 (for our setup; here: 100 nm) 
o “Emission Wavelength” = 700 (for Alexa Fluor 647) 
o “Noise” = 5 (for this sample; noise is the standard deviation of background from .tif blinking 

movie in photon counts) 
 Press “Compute” 

Evaluates the theoretical localization precision according to Thompson et al. and Mortensen 
et al. 

 Three output files: graphical presentation of the localization precision distribution according 
to Thompson et al. and Mortensen et al. (thom_acc.pdf and mort_acc.pdf respectively), list of 
localization uncertainties according to Thompson et al. (first column) and Mortensen et al. 
(second column) for every localization (theo_lac.txt) 



 After “…job done…”, select “Accuracy” tab, “Experimental” tab 
 Press “Compute NeNA” (NeNA = nearest neighbor analysis in adjacent frames) 

Evaluates the experimental localization precision according to Endesfelder et al.  
 Two output files: graphical presentation of distribution of nearest neighbor distances in 

adjacent frames according to Endesfelder et al. (NeNA_lac.pdf), list of distances in nm for 
every localization to its nearest neighbor in the next frame (NeNA_lac.txt) 

How do the values of the localization precision obtained from the three methods differ? If time, evaluate 
the localization precision for different samples (microtubules, Env etc.). Discuss the relationship of 
localization precision and spatial distribution. Keep these files for your results 

3.3 Morphological Cluster Analysis (MCA) 
 In “Main” tab, “ROI” tab: Define appropriate ROI (e.g. 10 μm x 10 μm), select all imaging 

frames (e.g. t [frames] = 0-11000) (use same image as above) 
 Select “Visualize” tab, “MCA” tab 

o enable “Enable Morphological Cluster Analysis” 
o set “Intensity Threshold” = 0.1 
o set “Minimum Cluster Radius” = 10 
o set “Maximum Cluster Radius” = 100 

 Press “Compute”  
 Three ouput files: binary image of clusters as masks (mask.png), image of identified clusters 

corresponding to masked regions (masked_roi.png), list of cluster parameters such as x/y 
position, size, intensity (mca_roi.txt) 

Comments: (i) “Intensity Threshold” is given in relative units with respect to maximum number of 
localizations in one pixel; (ii) locs_roi.txt, roi_int.png and offset.txt are updated according to the new ROI 
parameters (iii) If “Enable Convolution” is enabled in “Image” tab, cluster analysis is performed on blurred 
data. 

3.4 Cluster Analysis using Ripley’s Functions 
 In “Main” tab, “ROI” tab: Define appropriate ROI, select all imaging frames (e.g. t [frames] = 0-

11000) (use same image as above) 
 Select “Ripley’s K-Function” tab 

o set “Length ROI” = 1.5 (defines quadratic ROI of 1.5 µm length using only xmin and ymin of 
“Main” → “ROI” as starting points; this ROI contains all localizations for which Ripley’s 
analysis is performed) 

o set “Radius of Observation” = 1.5 (maximum radius for calculation of Ripley’s functions) 
o set “Number of Increments” = 150 (number of bins for Ripley’s functions) 

 Press “Compute” 
 Output folder “roi_0” contains five output files: plot of Ripley’s H function (ripley.pdf),  x/y 

values of the Ripley’s K, L and H functions (ripley.txt), localization file and image of selected 
ROI (roi_ripley.txt, roi_int.png), x/y coordinates for toroidal edge correction (TEC_locs.txt) 

Look at Hmax and rmax given in the ripley.txt file. Compare your results to the cluster analysis of TNFR1 
performed with the “Particle Analyze” function in Fiji (section 2.3). 
Repeat Ripley’s analysis for Env wt and Env ΔCT mutant. Compare the results! 


